Form Designer hangs when attempting to publish a form
Issue
When attempting to publish a
form in Form Designer to the XPA form Server it hangs. The progress bar goes to
approximately 70 percent then just hangs there.
Reason /
Possible Cause
There is a bad file
association with the .jnlp extension.
For example:
java.exe,javaw.exe,javaws.exe.
In order for The form
designer to publish properly it needs to be set to javaws.exe.
Solution
On the workstation running Form
Designer,
1. Verify
the version of Java being used is 7. If not, install Java version 7.
2. Kill
any Javaw.exe processes that are running.
a. Open
Task Manager.
b. Select
the Processes tab, search for javaw.exe processes.
Note: There may
be more than one Javaw.exe process.
c. Make
sure you select all javaw.exe.
3. Set
the System Environment Variable to point to Java 7 32-bit install directory.
Note: This also applies to 64 bit environments.
a. Click
Start | Computer.
b. Right-click
Computer | Properties.
c. Click
Advanced system settings. The System Properties window displays.
d. On
the Advanced tab click the Environment Variable button. The Environment
Variable window displays.
e. In
the System Variables box, find and then double-click JAVA_HOME. The Edit
System Variable window displays.
Note: Verify
that you are looking at the System Variables (not a user variable box).
f. The
Variable Name box should display JAVA_HOME.
g. The
Variable Value box may need to be edited to match the following example.
Example: c:\Program Files
(x86)\Java\Jre7
Note: Do not use the JAVA located C:\Program Files
(x86)\Xerox\XPA\FormDesigner\jre that is a 64 bit version.
Note: Additional
information on this can be found on page 2-12 of the XPA_Guide.
h. Click
the OK button.
i. Try
publishing the eForm again or launching the Management Console to see if this
resolves the issue. (If issue persists proceed to step 2).
4. Lower
the Java Security Setting.
Warning: Only the Network Administrator should change this security setting.
a. Click
Start | Control Panel | double-click Java. The Java Control Panel
window displays.
b. Click
the Security tab.
c. Next
to Security Level select Medium.
d. Verify
that your DocuShare Form Server is listed in the Exception Site List.
Note: If your site is not listed add it by clicking the Edit Site List.
Example: Error! Hyperlink reference not valid. Error! Hyperlink
reference not valid.>
e. Click
the OK button.
5. Check
the Java Settings in the Control Panel.
a. Open
the Control Panel and double click Java.
b. Select the Java tab
and click the View button. The Java Runtime Environment Settings window.
c. Select the User
tab, place a checkmark in the checkbox next to Java 1.6 (Usually 1.6 is
listed under the Platform section.
d. Remove checkmarks from
any other Java installations that are displayed.
6. Try
publishing a form again.
Solution
Updated: September 13, 2016
Solution ID: 1701
Keywords: XPA
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